Seeking advice on Bios on Motherboard that won't post

Hi Guys

I have an issue with an Asus Maximus III Formula Motherboard (same is in the pic below). Board starts up (led’s, cpu fan) . . . but won’t post anything to the monitor (which is working on another pc of course). . . The board was checked outside a pc case on a wooden desk to be sure that there is nothing which could cause a short on the bottom of the board.
I’ve also tried the following without any success . . . :disappointed::

  1. Reset Bios as per instructions in User’s Manual.
  2. 2 X Different GPU’s (both working in another pc).
  3. Different rams modules in various slots (ram is within recommended spec by Asus).
  4. Re-seated & Checked CPU to feel whether it heats up (to check whether it switches on).
  5. Different PSU (working perfectly in different pc).

I suspect a Failed Bios Software or Failed Bios Chip. There are No SPI Header on this board . . . but the Bios Chip is removable., , , But I don’t have a programmer to perform the operation - Lack of skill in this department also . . . Open to suggestions from the community on other avenues to pursue . . .

I’m also looking for some guidance on the way forward . . . as I wouldn’t want to ditch this board just yet. I would appreciate it and would welcome any suggestions on how to go about in fixing it.
Or if some might have a board such as this one that has been damaged in another way (perhaps bent pins or blown caps) . . . I would appreciate it if they could bless a fellow tinkerer with a donation of a bios chip . . . at a fee of course . . .

Much appreciating your help . . .

Regards.
NissaN

check you have the right bios version to support your cpu. if it was not working with current cpu of cause.

1 Like

Hi Nissan, does it gives you some beeps when booting? If so what is the seconds between them?

I would go this route:

Unplug everything…take out the CMOS Battery, try to replace with a new one, usually the CR2303 battery could be a culprit…had the same issue with my Z79 board.

After still not booting try one ram stick at a time, check that your PSU and Rset switch headers isn’t wired the wrong way around.

Check every connection, check for bend pins on the memory slots, mb cpu pins ect.

Does it have a dual bios, if so use the backup bios then.

2 Likes

Nissie beste bet, op wish is n usb bios writer reader, dan download die original bios en load dt weer op dai bios chip

2 Likes

Hey Guys

Thanks for all the replies and advice - I will keep at it and eventually might get it to work - but in my opinion a replacement bios chip would be the easiest and last resort . . . On the other hand . . . I kinda dig the idea of playing around with things that requires a bit of a challenge techically . . .

Will see how far I get with flashing the bios chip.

I searched a bit . . . And found that the usb bios programmers are actually not that expensive . . .

1 Like

This is most probably a bios issue, the mainboard could have been bricked due to error in the bios or failed bios update. Have you done an update before this happened? Have you tried to flash the cmos by removing the battery and changing the bios jumper config on the mainboard? Is the board still under warranty? If yes you could possibly log a call with the Vendor or supplier if it is. I have had a few bricked machines(Desktops and Laptops) that I have logged to their Vendors due to bricked mainboard so if it is still under warranty it can possibly get replaced if not then getting a replacement chip that is of course compatible will be your best bet.

2 Likes

Hey @Nemisis_Organdonor

Thanks for your reply and advice . . .
Unfortunately this board is No longer covered by any Warranties . . . My next best bet would be a replacement bios chip . . . (which I’m still hoping will pop up from the wood work somewhere :wink: )
or bios programmer to flash the bios chip which is currently on the board - Hopefully this did not incure any physical damage and will still accept the newly flashed firmware . . .

1 Like

@nissan

the last time I had MB problems I went straight to Mantech Electronics in Viking Estate, behind Grand West.

Had similar problems, I bought 2 blank bios chips and had dl the the new file on flash.
They have a flash eeprom readers on-site for clients to use.
Very helpful bunch. Try them they are forerunners in the industry and suppl,y the big boys…
Hope it works out.

Regards

5 Likes